Accessible Digital Office Document Project:
Authoring Techniques for Accessible Office Documents:
Adobe Acrobat 9 Pro
Version

Date of Current Version: 04 Feb 2011

Latest Version (HTML): http://inclusivedesign.ca/accessible-office-documents/acrobat9 
Quick Reference
2Usage Notes


3Technique 1. Use Accessible Source Documents


3Technique 2. Test for Accessibility Compliance


6Technique 3. Set a Logical Reading Order


7Technique 4. Edit and Add Navigational Aids


10Technique 5. Provide Text Alternatives for Images and Graphical Objects


12Technique 6. Set Document Properties


12Technique 7. Adjust Security Settings


13Technique 8. Use Other Features for Accessible Document Production


13Technique 9. Use Accessibility Features when Saving/Exporting to Other Formats


14Technique 10. Consider Using Accessibility Support Applications/Plugins


14Accessibility Help


14References and Resources


15Acknowledgments




Usage Notes
Overview

At the time of testing (January 19, 2011), Acrobat 9 Pro provides a set of accessibility features that is sufficient to enable the production of accessible digital office documents.  In addition, Acrobat 9 Pro includes an accessibility checking feature.
What’s an “Office Document”?

You should use these techniques when you are using Acrobat 9 Pro to create documents that are: 
· Intended to be used by people (i.e., not computer code),
· Text-based (i.e., not simply images, although they may contain images),
· Fully printable (i.e., where dynamic features are limited to automatic page numbering, table of contents, etc. and do not include audio, video, or embedded interactivity),
· Self-contained (i.e., without hyperlinks to other documents, unlike web content), and 
· Typical of office-style workflows (Reports, letters, memos, budgets, presentations, etc.).
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 If you are creating forms, web pages, applications, or other dynamic and/or interactive content, these techniques will still be useful to you, but you should also consult the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0) because these are specifically designed to provide guidance for highly dynamic and/or interactive content.
File Formats

The default file format for Acrobat 9 Pro is Adobe Portable Document Format (PDF). 

In addition, Acrobat 9 Pro offers many other word processor and web format saving options. Most of these have not been checked for accessibility, but some information and/or instructions are available for the following formats in Technique 9 (below):
· HTML

· Saving as accessible text
Document Conventions
We have tried to formulate these techniques so that they are useful to all authors, regardless of whether they use a mouse. However, for clarity there are several instances where mouse-only language is used. Below are the mouse-only terms and their keyboard alternatives:
*Right-click: To right-click with the keyboard, select the object using the Shift+Arrow keys and then press either (1) the “Right-Click” key (some keyboard have this to the right of the spacebar) or Shift+F10.
Disclaimer and Testing Details:
Following these techniques will increase the accessibility of your documents, but it does not guarantee accessibility to any specific disability groups.  In cases where more certainty is required, it is recommended that you test the office documents with end users with disabilities, including screen reader users.

The application-specific steps and screenshots in this document were created using Adobe Acrobat 9 Pro (ver.9.0.0, Windows 7, Jan. 2011) while creating a PDF document.  Files are also easily saved as other file formats (see Technique 9, below).
This document is provided for information purposes only and is neither a recommendation nor a guarantee of results. If errors are found, please report them to: adod-comments@idrc.ocad.ca. 
Technique 1. Use Accessible Source Documents
In the Adobe Acrobat 9 Pro workflow, all PDF documents start with a source document created in an office document authoring application, such as Microsoft Word or OpenOffice.org Writer.  Because source documents provide the starting-point for the PDF documents, accessibility is critical.
To create an accessible source document

1. Create a new document in the authoring application (from the default blank template or from one of the prepackaged templates)
2. Ensure that you follow the ADOD Authoring Techniques provided for the authoring application (available at: http://inclusivedesign.ca/accessible-office-documents)
3. When you are finished, you should also check the accessibility of the document (see “Accessibility Checking” in the Authoring Techniques for the authoring application)
Technique 2. Test for Accessibility Compliance

The best way to test the accessibility of a document is to attempt to use the document with the tools that your readers will use.  However, even if you don’t have a screen reader or other assistive device, you can use any of the following methods provided by Acrobat 9 Pro for checking the accessibility of a PDF.
2.1 Check for Tags

Creating a tagged document directly from an authoring application is the best way to make PDFs accessible.  However, if a PDF was created without tags, you can add them, using Add Tags to Document.  Often Acrobat tags PDFs when you create them. To learn more about tags, see Technique 3.1 below.
To determine whether a PDF contains tags

1. Go to menu item: File > Properties
2. Select Description tab

3. Look at the Tagged PDF value in the Advanced pane
Note: This can also be determined by running an Accessibility Quick Check (see Technique 2.2, below) 
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2.2 Run Accessibility Checks
For a more thorough review of the accessibility compliance of a document, use one of the accessibility check features available in Acrobat 9 Pro.  The Accessibility Quick Check examines the PDF to see if it has searchable text, document structure tags, and appropriate security settings to make it accessible.  To check for other types of accessibility problems, it is best to use the Accessibility Full Check.
To Use Accessibility Quick Check

1. Go to menu item: Advanced > Accessibility > Quick Check
To Use Accessibility Full Check
1. Go to menu item: Advanced > Accessibility > Full check
2. Under Report and Comment Options, select how you would like to view the results

3. If you would like to do a full check on individual sections of a document, under Page Range, select a page range

Note: when you have a large document, running a full check on one section at a time can be more efficient.

4. Under Checking Options, select an accessibility standard from the Name drop-down list

5. Under Checking Options, select Select All to run a complete accessibility check
6. Select Start Checking
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2.3 Test Using Reflow View
Reflowing a document temporarily presents it as a single column that is the width of the document pane.  Only readable text appears in the reflow view.  In this way, reflow can make the document easier to read in cases where it is difficult to scroll horizontally, such as on a mobile device or magnified on a standard monitor.

To quickly check the reading order of a document, view it in Reflow view.  If the tagged PDF does not reflow the way you want, it means that the content order or reading order of the PDF contains inconsistencies.  If this is the case, in addition to correcting the reading order (see Technique 4, below), it may also be helpful to check the tagging process (see Technique 2.1, above).  
Note: Before reflowing the document, Acrobat Pro 9 temporarily tags an untagged document.  You can optimize your PDFs for reflow by tagging them yourself (see Technique 3.1, below).

To reflow a tagged PDF
1. Go to menu item: View > Zoom > Reflow
2. To return to regular view, go to menu item: View > Zoom > Reflow
2.4 Test Using Read Out Loud
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 The “Read Out Loud” feature in Adobe Reader 9.4.2 for Windows currently does not read “alt” text for images [Tested: 11 February 2011]. This text can be read from within Adobe Reader by some screen readers.
The Read Out Loud feature reads the text in a PDF aloud in the available voices installed on your system.  In tagged PDFs, content is read in the order in which it appears in the document’s logical structure tree.  In untagged PDFs, the reading order is inferred.  The Read Out Loud feature can indicate problems or errors in the reading order and document structure.
To read a PDF with Read Out Loud
1. Go to menu item: View > Read Out Loud > Activate Read Out Loud
2. Navigate to the page that you want to read

3. Go to menu item: View > Read Out Loud > Read This Page Only or Read To End Of Document
4. To interrupt reading out loud, go to menu item: View > Read Out Loud > Pause or Resume or Stop
5. When you are finished using the Read Out Loud feature, go to menu item: View > Read Out Loud > Deactivate Read Out Loud
Technique 3. Set a Logical Reading Order
The order in which elements in a document are read by assistive software is determined by the reading order.  Each section of page content appears as a separate highlighted region and is numbered according to its placement in the reading order.  You can change the reading order of the highlighted regions without changing the actual appearance of the PDF.  For example, by reordering highlighted regions on the page, you can make a figure and caption read at the specific point that they are referenced in the text without actually moving the elements on the page.
To check reading order

1. Go to menu item: Advanced > Accessibility > TouchUp Reading Order…
2. Select Show Page Content Order
3. Check the reading order of text within each highlighted region in the document pane

4. Check the numbered order of all highlighted regions

5. Select Show Order Panel
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6. To find numbered regions that you cannot locate in the document pane, select each content entry in the Order tab to highlight that region in the document pane

To correct reading order

There are two ways to correct the reading order:
To correct the reading order with the order tab:
1. Go to menu item: Advanced > Accessibility > TouchUp Reading Order…
2. Select Show Order Panel
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3. In the Order tab, navigate through the list of highlighted regions that appear in the document pane

4. If a highlighted region is misplaced, right-click* and select Cut
5. Navigate to the location where the region should be placed, right-click* the item above the location in the list and select Paste
Note: You can complete steps 4 and 5 by dragging the tag for the region to the location you want.  As well, you can select and move multiple adjacent regions at once.  After you drag an item to a new location, the highlighted regions are renumbered accordingly. 

To correct reading order by dragging on the page

1. Go to menu item: Advanced > Accessibility > TouchUp Reading Order…
2. Select Show Page Content Order
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3. In the document pane, drag the region to where you want it to be read.  When you release the highlighted region, the underlying highlighted region is split into two new highlighted regions and the insertion point becomes the dividing line.  All highlighted regions are renumbered to show the new reading order.
Technique 4. Edit and Add Navigational Aids 
4.1 Document Structure Tags

PDF tags are a mechanism for indicating the organizational structure of documents (e.g., headings, paragraphs, sections, tables, and other page elements) without changing the visual appearance of the PDF.  These tags enable use with assistive devices, such as screen readers, indicate the document reading order and also enable mobile devices to reflow and display the document on a small screen.  
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 An untagged document does not have structural information, and Acrobat must infer a structure. This situation often results in page items being read in the wrong order or not at all.  For best results, tag the document when converting it to PDF from the authoring application.
To add tags automatically
1. Go to menu item: Advanced > Accessibility > Add Tags To Document
Note: This command removes any tags that were in the document before the command was run.  If any potential problems were encountered, an Add Tags Report appears in the navigation pane.

The automatic tagging feature is usually sufficient for most standard layouts, but it sometimes cannot correctly interpret the structure and reading order of complex page elements (e.g. closely spaced columns, irregular text alignment, and tables without borders.).  If your testing (see Technique 2) reveals problems, it is necessary to edit and add tags manually using the following techniques.
To add tags manually

1. Using the TouchUp Reading Order tool, drag within the document pane to select a region of the page that contains one type of content (e.g. a text block)

2. To add more page content to the current selection, Shift + drag
3. To remove page content from the current selection, Ctrl + drag
4. Select the appropriate button in the TouchUp Reading Order dialog to specify the tag type
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To change the tag for a region

1. Select the TouchUp Reading Order tool

2. In the TouchUp Reading Order dialog, select Show Page Content Order
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3. In the document pane, drag to select a highlight region or select the number of the highlighted region

4. Select the appropriate button in the TouchUp Reading Order dialog to specify the tag
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To add or remove content from a tagged region

1. Select the TouchUp Reading Order tool

2. In the TouchUp Reading Order dialog, select Show Page Content Order
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3. In the document pane, select a highlighted region

4. To add content, Shift + select the content

5. To remove content, Ctrl + select the content

6. Select the button for the tag type that you want for the highlighted region
To apply a heading tag

1. Select the TouchUp Reading Order tool

2. Select the heading text in the PDF

3. In the TouchUp Reading Order dialog, select the button corresponding to the appropriate heading tag

To remove page elements from the tag structure

1. Select the TouchUp Reading Order tool

2. In the TouchUp Reading Order dialog, select Show Page Content Order and Show Tables And Figures
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3. In the document pane, select the page element and select Background in the TouchUp Reading Order dialog, or select the page element in the Order tab and select Delete
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4.2 Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation pane.  Each bookmark goes to a different view or page in the document. In Acrobat 9 Pro, you can use bookmarks to mark a place in the PDF to which you want to return, or to jump to a destination in the PDF, another document, or a web page. 
Bookmarks are generated automatically during PDF creation from the table of contents entries and headings of documents created in most authoring tools. They are often tagged and can be used to make edits in the PDF. 
Note: An Acrobat user can add bookmarks to a document only if the security settings allow it.
To create a bookmark using keyboard shortcuts

1. Select Ctrl+B
2. Name the bookmark
3. Click outside the bookmark to deselect it
4. Navigate to the page that you want to link with the bookmark
5. Select the newly created bookmark in the Bookmarks panel
6. In the Options menu, select Set Bookmark Destination
To create a bookmark without keyboard shortcuts
1. Open the page where you want the bookmark to link to

2. To bookmark a single image, click the image and skip to Step 5
3. To bookmark a portion of an image, drag a rectangle around the portion and skip to Step 5
4. To bookmark selected text, select the text
5. Select the Bookmarks button and select the bookmark under which you want to place the new bookmark
6. Choose New Bookmark from the Options menu

7. Type or edit the name of the new bookmark
To edit a bookmark

1. Select the Bookmarks button

2. In the Bookmarks pane, select the bookmark

3. In the Options menu, select Rename Bookmark
4. Type the new bookmark name

To change a Bookmarks destination

1. Select the Bookmarks button

2. In the Bookmarks pane, select the bookmark

3. In the document pane, move to the location you want to specify as the new destination

Note: If necessary, adjust the view magnification.
4. In the Options menu, select Set Bookmark Destination
To delete a bookmark

1. Select the Bookmarks button

2. In the Bookmarks pane, select a bookmark or range of bookmarks

3. Select Delete
To create a bookmark hierarchy

1. Select the Bookmarks button

2. In the Bookmarks pane, select the bookmark or range of bookmarks you want to nest

3. Drag the icon or icons directly underneath the parent bookmark

Note: The bookmarks are nested, but the actual page remains in its original location in the document.

To remove bookmarks from a hierarchy

1. Select the Bookmarks button

2. In the Bookmarks pane, select the bookmark or range of bookmarks

3. Move the selection by dragging the icons or select Cut from the Options menu, select the bookmark and select Paste Under Selected Bookmark from the Options menu 
Technique 5. Provide Text Alternatives for Images and Graphical Objects
When using images or other graphical objects, such as charts and graphs, it is important to ensure that the information you intend to convey by the image is also conveyed to people who cannot see the image.  This can be accomplished by adding concise alternative text to of each image. If an image is too complicated to concisely describe in the alternative text alone (artwork, flowcharts, etc.), provide a short text alternative and a longer description as well. 
Tips for writing alternative text
· Try to answer the question "what information is the image conveying?"
· If the image does not convey any useful information, leave the alternative text blank
· If the image contains meaningful text, ensure all of the text is replicated
· Alternative text should be fairly short, usually a sentence or less and rarely more than two sentences
· If more description is required (e.g., for a chart or graph), provide a short description in the alternative text (e.g., a summary of the trend) and more detail in the long description, see below
· Test by having others review the document with the images replaced by the alternative text
Tips for writing longer descriptions
· Long descriptions should be used when text alternatives (see above) are insufficient to answer the question "what information is the image conveying?"
· In some situations, the information being conveyed will be how an image looks (e.g., an artwork, architectural detail, etc.). In these cases, try to describe the image without making too many of your own assumptions.
· One approach is to imagine you are describing the image to a person over the phone
· Ensure that you still provide concise alternative text to help readers decide if they are interested in the longer description
Alternatively, you can include the same information conveyed by the image within the body of the document, providing the images as an alternate to the text. In that case, you do not have to provide alternate text within the image.
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 Only add alternative text to tags that don’t have child tags.  Adding alternative text to a parent tag prevents assistive software from reading any of that tag’s child tags.
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 The “Read Out Loud” feature in Adobe Reader 9.4.2 for Windows currently does not read “alt” text for images [Tested: 11 February 2011]. This text can be read from within Adobe Reader by some screen readers.
To add alternative text to images or graphical objects
1. Go to menu item: View > Navigation Panels > Tags
2. In the Tags tab, select the element
3. Right-click* the element and select Properties…
4. In the Tag tab, fill in the alternative text in the Alternative Text box
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5. Select Close
To add alternative text to figures and tables
1. Save the document

Note: Changes using this technique cannot be undone, reverting to a saved document will be the only way to undo a change.

2. Go to menu item: Advanced > Accessibility > TouchUp Reading Order…
3. Select the element by drawing a rectangle around the content
4. In the TouchUp Reading Order dialog, select Figure or Table
5. Right-click* the element and select Edit Alternate Text…
6. Enter the alternative text in the Alternate Text box
7. Select OK
To add alternative text to links
1. In the tag tree, select the Link tag for the link
2. Select Options > Properties
3. In the TouchUp Properties dialog, select the Tag tab

4. Type alternative text for the link

5. Select Close
Technique 6. Set Document Properties

6.1 Document Language
In order for assistive technologies (e.g., screen readers) to be able to present your document accurately, it is important to indicate the natural language of the document.  If a different natural language is used for a paragraph or selected text, this also needs to be clearly indicated.
To change the default language

1. Go to menu item: File > Properties
2. Select the Advanced tab

3. In the Reading Options section, select the language from the Language drop-down list

4. Select OK
To apply a language directly to selected element
1. Go to menu item: View > Navigation Panels > Tags
2. In the Tags tab, select the element

3. Right-click* the element and select Properties…
4. In the Tag tab, select the language from the Language drop-down list

5. Select Close
6.2 Document Title

In case the document is ever converted into HTML, it should be given a descriptive and meaningful title. 
To change the title of the current document
1. Go to menu item: File > Properties
2. Select the Description tab

3. Enter a descriptive title in the Title box.  It is also helpful to enter descriptive information in the text boxes that follow (Author, Subject, Keywords or select Additional Metadata)

4. Select OK
Technique 7. Adjust Security Settings

It is possible to specify that no part of an accessible PDF is to be copied, printed, extracted, commented on, or edited.  This can be accomplished by encrypting the document with password security.  However, this could interfere with a screen reader’s ability to read the document, because screen readers must be able to copy or extract the document’s text in order to convert it to speech.  In Acrobat 9 Pro, it is possible to maintain high-encryption-level security while at the same time providing the necessary access to assistive technologies.
To allow assistive technologies access to content
1. Go to menu item: Advanced > Security > Encrypt with Password
2. In the Password Security - Settings dialog, under Permissions, select Restrict editing and printing of the document 

3. For low-encryption-level security, select Enable copying of text, images, and other content  

4. For high-encryption-level security, select Enable text access for screen reader devices for the visually impaired (this overrides the document’s security settings only for the purpose of giving assistive software, such as screen readers, access to the content)
5. Select OK
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Technique 8. Use Other Features for Accessible Document Production
8.1 Accessible Forms

A workflow for creating accessible PDF forms can be found in:
· Adobe Help Documentation
· Adobe Acrobat 9 Accessibility Guide: Creating Accessible Forms
8.2 Scanned Pages

If you created a PDF from of a scanned document, then it will be inherently inaccessible to screen readers and other assistive technologies. In addition, the document will be less useful because graphic representations of text cannot be selected, edited or searched.  In this case, it is necessary that you convert the scanned images of text to searchable content using optical character recognition (OCR) before addressing the accessibility features of the document.  Help can be found in:

· Recognize text in scanned documents
Technique 9. Use Accessibility Features when Saving/Exporting to Other Formats
In some cases, additional steps must be taken in order to ensure accessibility information is preserved when saving/exporting to formats other than the default.
To save as accessible text

1. Go to menu item: File > Save As
2. In the File name box, type a name for the file

3. In the Save as type box, select Text (Accessible) or if you are saving the file for further Braille processing you can also select .doc or .rtf
4. Select Save
HTML
1. Go to menu item: File > Export As > HTML 
2. In the File name box, type a name for the file

3. Select Settings…
4. Ensure Generate bookmarks and Generate tags for untagged files are selected
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5. Select OK
6. Check the HTML file for accessibility (see Technique 2, above)
To clean up your HTML file

1. Remove unnecessary styles, line breaks, etc.

2. Remove unnecessary id, class, and attributes

3. Remove font tags

4. Remove styles in the <head> tag

5. Ensure the <th> tags have a scope attribute

6. Remove <p> tags nested inside <th> and <td> tags

7. Check for accessibility (see Technique 2, above)

Note: you may wish to use HTML editors or utilities to help with this process.
Technique 10. Consider Using Accessibility Support Applications/Plugins

Disclaimer: This list is provided for information purposes only. It is not exhaustive and inclusion of an application or plug-in on the list does not constitute a recommendation or guarantee of results by the IDRC.
The following accessibility-related plug-in are associated with Acrobat 9 Pro:
· Adobe Acrobat Help and Support
· Using Adobe Acrobat 9
· Adobe Accessibility Training Resources
Accessibility Help
If you are interested in what features are provided to make using Acrobat 9 Pro more accessible to users, documentation is provided in the Help system: 
1. Go to menu item: Help > Adobe Acrobat 9 Pro Help
2. Browse Contents tree for help, or select Search
3. Enter “Accessibility” as your search term in the Search text box
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