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Usage Notes
Overview

At the time of testing (August 20, 2010), WordPerfect X5 provides a set of accessibility features that is sufficient to enable the production of accessible digital office documents. However, WordPerfect X5 does not include an accessibility checking feature.
What’s an “Office Document”?

You should use these techniques when you are using WordPerfect X5 to create documents that are: 
· Intended to be used by people (i.e., not computer code),
· Text-based (i.e., not simply images, although they may contain images),
· Fully printable (i.e., where dynamic features are limited to automatic page numbering, table of contents, etc. and do not include audio, video, or embedded interactivity),
· Self-contained (i.e., without hyperlinks to other documents, unlike web content), and 
· Typical of office-style workflows (Reports, letters, memos, budgets, presentations, etc.).
If you are creating forms, web pages, applications, or other dynamic and/or interactive content, these techniques will still be useful to you, but you should also consult the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0) because these are specifically designed to provide guidance for highly dynamic and/or interactive content.
File Formats

The default file format for WordPerfect X5 is WordPerfect format (WPD).
In addition, WordPerfect X5 offers many other word processor and web format saving options. Most of these have not been checked for accessibility, but some information and/or instructions are available for the following formats in Technique 12 (below):
· MS Word 

· PDF 

· HTML

Document Conventions
We have tried to formulate these techniques so that they are useful to all authors, regardless of whether they use a mouse. However, for clarity there are several instances where mouse-only language is used. Below are the mouse-only terms and their keyboard alternatives:

*Right-click: To right-click with the keyboard, select the object using the Shift+Arrow keys and then press either (1) the “Right-Click” key (some keyboard have this to the right of the spacebar) or Shift+F10.

Disclaimer and Testing Details:
Following these techniques will increase the accessibility of your documents, but it does not guarantee accessibility to any specific disability groups.  In cases where more certainty is required, it is recommended that you test the office documents with end users with disabilities, including screen reader users.

The application-specific steps and screenshots in this document were created using Corel WordPerfect X5 (ver.15.0.0.357, Windows XP, Sept. 2010) while creating a document in WordPerfect format. Files are also easily saved as other file formats (see Technique 12, below).
Technique 1. Use Accessible Templates
All office documents start with a template, which can be as simple as a blank standard-sized page or as complex as a nearly complete document with text, graphics and other content. For example, a “Meeting Minutes” template might include headings for information relevant to a business meeting, such as “Actions” above a table with rows to denote time and columns for actions of the meeting.
Because templates provide the starting-point for so many documents, accessibility is critical. If you are unsure whether a template is accessible, you should check a sample document produced when the template is used (see Technique 11, below). 

WordPerfect X5’s default template for new documents is a blank page. The basic installation also includes blank label templates and blank business reports.  These are all accessible by virtue of being blank.

It is possible to create your own accessible templates from scratch in WordPerfect X5.  As well, you can edit and modify the existing prepackaged templates, ensuring their accessibility as you do so and saving them as a new template.
To create an accessible template
1. Create a new document

2. Go to menu item: File > New from Project… (Ctrl+Shift+N)

3. Select Options
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4. Select Create WP Template from the drop-down menu
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5. Ensure that you follow the techniques in this document

6. When you are finished you should also check the accessibility of the document (see Technique 11, below)

7. Go to menu item: File > Save As
8. Fill in the Description box with a statement that identifies the file as an accessible template (e.g., “This memo template has been checked for accessibility”).  Using terms such as “accessible” will improve its searchability as an accessible file.

9. In the Template name box, type a name for the template.  Using a descriptive Template name (e.g. “Accessible Memo Template”) will increase the prominence of the accessibility status.

10. Under Template category, select a relevant category from the scrolling list

11.  Select OK
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To edit an existing template
1. Create a new document

2. Go to menu item: File > New from Project… (Ctrl+Shift+N)

3. Search for a template relevant to your needs by either selecting search criteria from the drop-down menu, or selecting a template directly from the scrolling list
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4. Select Options
5. Select Edit WP Template from the drop-down menu
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6. A pop-up will appear, with the statement: “You may edit the document, but you must save it with a new name.  Continue?” Select Yes
7. Ensure that you edit the template to follow the techniques in this document

8. When you are finished you should also check the accessibility of the document (see Technique 11, below)
9. Go to menu item: File > Save As
10. In the Description box, add a statement which indicates that the template is accessible.  This will improve its searchability as an accessible file.

11. In the Template name box, type a name for the template.  Using a descriptive Template name (e.g. “Accessible Memo Template”) will increase the prominence of the accessibility status. 

12. Under Template category, select a relevant category from the scrolling list
13. Select OK
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To select an accessible template
1. Go to menu item: File > New from Project… (Ctrl+Shift+N)

2. From the drop-down menu, select the category of your template.

3. Select your template from the scrolling list.  Its description should appear at the bottom of the dialog box when you select the template.
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4. Select Create
5. A new document based on the template will be displayed. If you have chosen an accessible template, the document will be accessible at this point. As you add your content (e.g., text, images, etc.), ensure that you consult the sections that follow to preserve accessibility.
Technique 2. Specify Document Language
In order for assistive technologies (e.g., screen readers) to be able to present your document accurately, it is important to indicate the natural language of the document.  If a different natural language is used for a paragraph or selected text, this also needs to be clearly indicated.
To change the default language
1. Go to menu item: Tool > Language > Settings…
2. Select the language from the scrolling list under Current language 
3. Select OK
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To apply a language directly to selected text
1. Highlight the text
2. Go to menu item: Tool > Language > Settings…
3. Select the language from the scrolling list under Current language 
4. Select OK
Technique 3. Provide Text Alternatives for Images and Graphical Objects
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 At this time, WordPerfect X5 does not make it possible to separate alternative text and longer descriptions.  [Tested: September 2010] If a longer description is necessary, you can include it in the alternative text box.

When using images or other graphical objects, such as charts and graphs, it is important to ensure that the information you intend to convey by the image is also conveyed to people who cannot see the image.  This can be accomplished by adding concise alternative text to of each image. If an image is too complicated to concisely describe in the alternative text alone (artwork, flowcharts, etc.), provide a short text alternative and a longer description as well. 
Tips for writing alternative text
· Try to answer the question "what information is the image conveying?"
· If the image does not convey any useful information, leave the alternative text blank
· If the image contains meaningful text, ensure all of the text is replicated
· Alternative text should be fairly short, usually a sentence or less and rarely more than two sentences
· If more description is required (e.g., for a chart or graph), provide a short description in the alternative text (e.g., a summary of the trend) and more detail in the long description, see below
· Test by having others review the document with the images replaced by the alternative text
Tips for writing longer descriptions
· Long descriptions should be used when text alternatives (see above) are insufficient to answer the question "what information is the image conveying?"
· In some situations, the information being conveyed will be how an image looks (e.g., an artwork, architectural detail, etc.). In these cases, try to describe the image without making too many of your own assumptions.
· One approach is to imagine you are describing the image to a person over the phone
· Ensure that you still provide concise alternative text to help readers decide if they are interested in the longer description
Alternatively, you can include the same information conveyed by the image within the body of the document, providing the images as an alternate to the text. In that case, you do not have to provide alternate text within the image.
To add alternative text to images and graphical objects
1. Right-click* the object
2. Select HTML Properties…
3. Select the Image tab in the HTML Properties dialog box
4. Fill in the Alternate Text box
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Technique 4. Avoid “Floating” Elements
When images and objects are inserted into WordPerfect X5 documents they default to being attached to the paragraph.  There is also the option to attach images and objects to the character or the page.  

A “floating” object keeps its position relative to the page, while text flows around it.  As content moves up or down on the page, the object stays where it was placed.  To ensure that images and objects remain with the text that references it, always position it as attached to a character at the end of the in-text reference.

Similarly, avoid placing drawing objects directly into the document (e.g., as borders, to create a diagram). Instead, create borders with page layout tools and insert complete graphical objects.
To prevent an image or object from “floating”
1. Select the object
2. Right-click* and select Position…
3. In the Box Position dialog, select the Attach box to drop-down menu
4. Select Character
5. Select OK
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Technique 5. Use Headings
Any documents that are longer than a few paragraphs require structuring to make them more straightforward for readers to understand. One of the easiest ways to do this is to use “True Headings” to create logical divisions between paragraphs. True headings are more than just bolded, enlarged, or centered text; they are structural elements that order and levels provide a meaningful sequence to users of assistive technologies.
Tips for headings
· Use the default headings styles provided (“Heading “, “Heading 2”, etc.)
· Nest headings properly (e.g., the sub-headings of a “Heading 1” are “Heading 2”, etc.)
· Do not skip heading levels
To apply headings to selected text
1. Highlight selected text

2. Go to menu item: Format > Styles… (Alt+F8)

3. Select the style you would like to apply from the list on the left of the Styles dialog

4. Select Insert
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To apply headings using the Styles toolbar
1. Highlight selected text

2. Select the Headings drop-down menu from the Property Bar
3. Select the heading style from the list

To modify heading styles
1. Go to menu item: Format > Styles… (Alt+F8)

2. In the Styles dialog, select Create…
3. In the Styles Editor dialog, enter unique name for the style in the Style name text box

4. Enter a description in the Description text box

5. Format the style using the available formatting options (e.g. font character, size, etc.), ensuring that your selections align with the techniques in this document

6. Select OK
Technique 6. Use Named Styles
As with “True Headings” (see Technique 5, above), you should attempt to make use of the named styles that are included with the office application (e.g., “emphasis”, “caption”, etc.) before creating your own styles or using the character formatting tools directly. Named styles help your readers understand why something was formatted in a given way, which is especially helpful when there are multiple reasons for the same formatting (e.g., it is common to use italics for emphasis, Latin terms and species names).
For more information on formatting using named styles, see Technique 9.
Note: While office application suites support headings in much the same way, the named styles often differ. 
To use default named styles
1. Default named styles can be applied the same way as headings (see Technique 5, above).
 Technique 7. Use Built-In Document Structuring Features

7.1 Tables

When using tables, it is important to ensure that they are clear and appropriately structured. This helps all users to better understand the information in the table and allows assistive technologies (e.g., screen readers) to provide context so that the information within the table can be conveyed in a meaningful way. 
Tips for tables
· Only use tables for tabular information, not for formatting, such as to position columns.

· Use “real tables” rather than text formatted to look like tables using the TAB key or space bar. These will not be recognized by assistive technology.
· Keep tables simple by avoiding merged cells and dividing complex data sets into separate smaller tables, where possible.

· If tables split across pages, set the header to show at the top of each page. Also set the table to break between rows instead of in the middle of rows.
· Create a text summary of the essential table contents. Any abbreviations used should be explained in the summary. 
· Table captions or descriptions should answer the question "what is the table's purpose and how is it organized?" (e.g., "A sample order form with separate columns for the item name, price and quantity").  
· Table cells should be marked as table headers when they serve as labels to help interpret the other cells in the table.
· Table header cell labels should be concise and clear.
· Ensure the table is not “floating” on the page (see Technique 4)
To add a table with headings
1. Go to menu item: Table > Create… (F12)
2. In the Create Table dialog, configure the dimensions of your table

3. Select Create
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4. Go to menu item: Table > Format… (Ctrl+F12)

5. In the Properties for Table Format dialog, select the Row tab

6. Select the Header Row (repeats on each page) check box

7. Select OK
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7.2 Lists
When you create lists, it is important to format them as “real lists”. Otherwise, assistive technologies will interpret your list as a series of short separate paragraphs instead of a coherent list of related items.
To create an ordered or unordered list

1. Go to menu item: Insert > Outline/Bullets & Numbering…
2. In the Bullets & Numbering dialog box, select the Numbers or Bullets tab

3. Select the list style from the menu

4. Select OK
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To create an ordered or unordered list using the Menu Bar
1. Highlight the text you would like to make into a list

2. From the Menu Bar, select the Numbered List or Bulleted List icon

Note: Clicking the arrow beside the icon opens a drop-down menu with different list style options.  To open the Bullets & Numbering dialog box, click More from the drop-down menu.
3. Select the list style you would like to use
To modify list styles
1. Go to menu item: Insert > Outline/Bullets & Numbering…
2. In the Bullets & Numbering dialog box, select the Numbers or Bullets tab

3. Select Create…
4. In the Create Format dialog, enter a name for the list style in the List name text box

5. Enter a description in the Description text box

6. Format your list using the available formatting options, ensuring your selections align with the techniques in this document
7. Select OK
7.3 Columns

Use Columns feature for placing text in columns. 
Note: Because columns can be a challenge for users of some assistive technologies, consider whether a column layout is really necessary.

7.4 Page Breaks

Start a new page by inserting a page break instead of repeated hard returns.

7.5 Use a Table of Contents
Creating an index or table of contents to outline office document content can provide a means of navigating the meaningful sequence of content.  
The best way to generate a table of contents is after applying the predefined heading styles, such as "Heading 1" as described above, to the headings that you want to include in your table of contents. After you apply these styles, you can then create a table of contents.
Note: In WordPerfect X5, the process for initially generating a table of contents is the same as the process for updating the table of contents.
To generate and update a Table of Contents
1. Go to menu item: Tools > Reference > Table of Contents
2. Select Generate
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3. In the Generate dialog box, enable the Save subdocuments and Build hyperlinks check boxes
4. Select OK
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7.6 Use Page Numbering

Numbering the pages of your document helps those reading and editing your document effectively navigate and reference its content.  For users of assistive technologies, it provides a valuable point of reference within the document.

To insert page numbers

1. Go to menu item: Format > Page > Numbering
2. In the Select Page Numbering Format dialog, select a position for the page number from the Position drop-down list

3. Select a format for the page numbers from the Page numbering format list

4. Select Font to open the Page Numbering Font dialog

5. In the Page Numbering Font dialog, select an appropriate font from the scrolling Face list and select an appropriate font size from the Size drop-down list

Note: You many also apply other attributes, such as bold from the check-box options listed under Appearance.

6. Select OK
To format page numbers

1. Go to menu item: Format > Page > Numbering
2. In the Select Page Numbering Format dialog, select Font…

3. In the Page Numbering Font dialog, select your font face, size, and appearance ensuring that your choices align with the techniques in this document

4. Select OK
5. In the Page Numbering Font dialog, select Custom Format…
6. In the Custom Page Numbering dialog, format your page number style using the available formatting options

7. Select OK
7.7 Document Title
In case the document is ever converted into HTML, it should be given a descriptive and meaningful title. 
To change the title of the current document

1. Go to menu item: File > Properties…
2. In the Properties dialog box, select the Summary tab

3. In the Descriptive name box, type a descriptive name for the document
Note: The Descriptive name defined in the properties is different than the file name. It is also unrelated to the template name, discussed above. 
Technique 8. Create Accessible Charts
Charts can be used to make data more understandable for some audiences.  However, it is important to ensure that your chart is as accessible as possible to all members of your audience.  All basic accessibility considerations that are applied to the rest of your document must also be applied to your charts and the elements within your charts.  For example, use shape and color, rather than color alone, to convey information.  As well, some further steps should be taken to ensure that the contents are your chart are appropriate labeled to give users reference points that will help them to correctly interpret the information. 

To create a chart
1. Go to menu: Insert > Chart…
2. Update the datasheet with the data you would like to display

3. Close the datasheet
To add titles and labels
1. Select the chart
2. Go to menu item: Chart > Title…
3. In the Title Properties dialog, ensure the Display chart title check box is selected

4. Enter a title in the Display chart title text box and select OK
5. Go to menu item: Chart > Subtitle…
6. In the Subtitle Properties dialog, ensure the Display chart subtitle check box is selected

7. Enter a subtitle in the Display chart subtitle text box and select OK
8. Go to menu item: Chart > Legend…
9. In the Legend Properties dialog, use the selections to format the legend

10. In the Legend title text box, enter a title for the legend and select OK
11. Go to menu item: Chart > Data Labels…
12. In the Data Labels dialog, use the selections to format the data labels

13. Ensure the Display data labels check box is selected

14. Select OK
To change to a different predefined Chart Type

1. Select the chart
2. Go to menu item: Chart > Layout/Type
3. In the Layout/Type Properties dialog, select a chart from the Chart type drop-down list

4. Select a Style and format the Appearance
5. Select OK
Other Chart Considerations

· When creating line charts, use the formatting options to create different types of dotted lines to facilitate legibility for users who are color blind
· When creating bar charts, it is helpful to apply textures rather than color to differentiate the bars
· Change the default colors to a color safe or gray-scale palette

· Use the formatting options to change predefined colors, ensuring that they align with sufficient contrast requirements (see Technique 9.2, below) 
Technique 9. Make Content Easier to See
9.1 Format of Text
When formatting text, especially when the text is likely to printed, try to:
· Use font sizes between 12 and 18 points for body text.

· Use fonts of normal weight, rather than bold or light weight fonts.  If you do choose to use bold fonts for emphasis, use them sparingly. 

· Use standard fonts with clear spacing and easily recognized upper and lower case characters. Sans serif fonts (e.g., Arial, Verdana) may sometimes be easier to read than serif fonts (e.g., Times New Roman, Garamond).
· Avoid large amounts of text set all in caps, italic or underlined.

· Use normal or expanded character spacing, rather than condensed spacing.
· Avoid animated or scrolling text.
But can’t users just zoom in?  Office applications do typically include accessibility features such as the ability to magnify documents and support for high contrast modes. However, because printing is an important aspect of many workflows and changing font sizes directly will change documents details such the pagination, the layout of tables, etc., it is best practice to always format text for a reasonable degree of accessibility.
To change the text size for a default named style
1. Go to menu item: Format > Styles… (Alt+F8)
2. In the Styles dialog, select the named style you want to change

3. Select Edit
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4. In the Styles Editor, select the font size drop-down menu

5. Select a font size between 12 and 18 points

6. Select OK
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9.2 Use Sufficient Contrast
The visual presentation of text and images of text should have a contrast ration of at least 4.5:1. To help you determine the contrast, here are some examples on a white background:
· Very good contrast (Foreground=black, Background=white, Ratio=21:1)
· Acceptable contrast (Foreground=#767676, Background=white, Ratio=4.54:1)
· Unacceptable contrast (Foreground=#AAAAAA, Background=white, Ratio=2.32:1)
Also, always use a single solid color for a text background rather than a pattern.
In order to determine whether the colors in your document have sufficient contrast, you can consult an online contrast checker, such as: 
· Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

· Joe Dolson Color Contrast Spectrum Tester
· Joe Dolson Color Contrast Comparison
9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying information, indicating an action, prompting a response, or distinguishing a visual element.  In order to spot where color might be the only visual means of conveying information, you can create a screenshot of the document and then view it with online gray-scale converting tools, such as:

· GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool
9.4 Avoid Relying on Sensory Characteristics
The instructions provided for understanding and operating content should not rely solely on sensory characteristics such as the color or shape of content elements. Here are two examples:
· Do not track changes by simply changing the color of text you have edited and noting the color. Instead use WordPerfect X5’s document review functionality feature to track changes.
· Do not distinguish between images by referring to their appearance (e.g. “the bigger one”). Instead, label each image with a figure number and use that for references.
9.5 Avoid Using Images of Text
Before you use an image to control the presentation of text (e.g., to ensure a certain font or color combination), consider whether you can achieve the same result by styling “real text”. If this is not possible, as with logos containing stylized text, make sure to provide alternative text for the image following the techniques noted in Technique 3, above.
Technique 10. Make Content Easier to Understand

10.1 Write Clearly
By taking the time to design your content in a consistent way, it will be easier to access, navigate and interpret for all users:
· Whenever possible, write clearly with short sentences.
· Introduce acronyms and spell out abbreviations.
· Avoid making the document too “busy” by using lots of whitespace and by avoiding too many different colors, fonts and images.
· If content is repeated on multiple pages within a document or within a set of documents (e.g., headings, footings, etc.), it should occur consistently each time it is repeated.  
10.2 Provide Context for Hyperlinks

Hyperlinks are more effective navigation aids when the user understands the likely result of following the link. Otherwise, users may have to use trial-and-error to find what they need.

To help the user understand the result of selecting a hyperlink, ensure that the link makes sense when read in the context of the text around it. For example, while it would be confusing to use “more information” as a link by itself on a page, it would be fine to use “more information” as a link in the following sentence: “The airport can be reached by taxi or bus (more information).”

To make the address of hyperlink clear when printing, you may wish to include the address in brackets following the descriptive text of the hyperlink.

To add hyperlinks with meaningful text
1. Go to menu item: Tools > Settings
2. In the Settings dialog box, click Environment
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3. In the Environment settings dialog, select the General tab

4. Disable the Activate hyperlinks check box

5. Select OK
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6. In the Settings dialog, select Close
7. Edit the hyperlink text

Note: While editing the hyperlink text, you have deactivated all hyperlinks in the document.  The following steps will allow you to reactive all hyperlinks after you have finished editing their text.

8. Go to menu item: Tools > Settings
9. Select Environment
10. In the Environment settings dialog, select the General tab

11. Enable the Activate hyperlinks check box
Technique 11. Check Accessibility
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 At this time, WordPerfect X5 does not offer a mechanism for checking and reviewing potential accessibility errors prior to publishing. [Tested: September 30th, 2010]
In order to get some indication of the accessibility of your document or template (see Technique 1), then you may consider saving the file into HTML or PDF in order to perform an accessibility check in one of those formats, as described below.
To evaluate HTML accessibility
Save the document into HTML format and use one of the web accessibility checkers available online.  Such as:
· AChecker
· WebAIM Wave Web Accessibility Evaluation Tool
To evaluate PDF accessibility

If you saved your document in tagged PDF format, you can use the following tools and steps to evaluate the accessibility of the PDF document:

· Adobe Acrobat Professional

· PDF Accessibility Checker (PAC) – a free alternative provided by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional

1. Go to menu item: Advanced > Accessibility > Full Check…
2. In the Full Check dialog, select all the checking option

3. Select the Start Checking button
Technique 12. Use Accessibility Features when Saving/Exporting to Other Formats
In some cases, additional steps must be taken in order to ensure accessibility information is preserved when saving/exporting to formats other than the default.
PDF
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 PDF documents are not always accessible. Accessible PDF documents are often called “Tagged PDF” because they include “tags” that encode structural information required for accessibility.  To evaluate the accessibility of your PDF document, see Technique 11 (above).
1. Go to menu item: File > Publish to PDF
2. In the PDF Style drop-down menu, select the type of PDF document

Note: You can save a WordPerfect X5 document in archival PDF formats (PDF/A-1a and PDF/A-1b), which are automatically generated as tagged PDF documents.  If you select either of these PDF types, you can skip directly to step 7.

3. In the Publish to PDF dialog, select Settings
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4. In the Publish to PDF Settings dialog box, select the Document tab

5. Enable the Generate tagged PDF check box
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6. Select OK
7. In the Publish to PDF dialog, select the drive and folder you want to save the file in

8. Type a meaningful file name in the Filename box

9. Select Save
Note: If errors are found in the file, a warning message appears.  You can view the errors in the generated log file.
HTML
1. Go to menu item: File > Publish to > HTML
2. In the HTML filename box, type a name

3. Select Publish
To clean up your HTML file

1. Remove unnecessary styles, line breaks, etc.

2. Remove unnecessary id, class, and attributes

3. Remove font tags

4. Remove styles in the <head> tag

5. Ensure the <th> tags have a scope attribute

6. Remove <p> tags nested inside <th> and <td> tags

7. Check for accessibility (see Technique 11, above)

Note: you may wish to use HTML editors or utilities to help with this process.
Technique 13. Consider Using Accessibility Support Applications/Plugins

Disclaimer: This list is provided for information purposes only. It is not exhaustive and inclusion of an application or plug-in on the list does not constitute a recommendation or guarantee of results.
· WordPerfect Office X5 Tutorials
· WordPerfect Office X5 Tips and Tricks
Accessibility Help
If you are interested in what features are provided to make using WordPerfect X5 more accessible to users, documentation is provided in the Help system: 
1. Go to menu item: Help > Help Topics… (F1)
2. Select the Search tab in the left pane
3. Enter “accessibility features” as your search term in the search box
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