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Guide For Making PDF Documents Accessible
Section 508

Accessibility of Electronic and Information Technology 

for People with Disabilities

INTRODUCTION

Scanned PDFs Versus Text PDFs

Scanned PDFs are essentially a picture of a document. Just like a paper copy, the information is not accessible to people who are blind and to many people who have low vision. Text PDFs, however, can be accessible if they are prepared correctly.

You get a Text PDF by—

· Converting the source document to a PDF directly from the source application using a PDFMaker.

· Converting scanned (image) PDFs to text with an Optical Character Recognition (OCR) tool.

Distinguishing Between Scanned and Text PDFs

How do you know if a file is a scanned PDF or a text PDF? 

· There are two easy ways:

· Use the Text tool in Acrobat and see if you can highlight text in the document. If you can't, the document has not been rendered by an OCR tool, and assistive technology will not be able to read it. 

· Use the Quick Check feature in Acrobat. Go to the Advanced menu, select Accessibility and then Quick Check. If the document is an image (scanned PDF), a message will appear saying the document appears to contain no text.

· If you can highlight the text or the Quick Check recognizes text, go to the Text PDFs section.

· If you cannot highlight the text or the Quick Check does not recognize text, go to the Scanned PDFs section.

Scanned PDFs

Although it is better to create the PDF from the source application, sometimes you must begin with a scanned document because you don’t have the electronic source file (Word, Excel, etc.). A scanned document is an image file until it goes through the OCR process.

· If you only have a paper copy, scan your document with your scanner set for grayscale scanning and text and images. If your document is scanned using a setting other then grayscale, the resulting PDF will be color indexed, and Acrobat might interpret the text as image objects and not text. If this occurs, you must use a graphics program to change the image to grayscale. 

· Use at least 300 dpi (dots per inch). The greater the resolution (higher number), the better your results will be.

· If you scanned the document as an image PDF or you have an existing scanned PDF, you must render the text with an OCR tool. Although you can use any OCR software like OmniPage or ScanSoft (which might be more suitable for large documents), these instructions discuss the OCR tool built into Acrobat Professional 7.x. 

Converting a Scanned Document to Text 

To perform OCR in Acrobat—

1. Go to the Document menu, select Recognize Text Using OCR and then Start.
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Figure 1. Path for accessing the Acrobat OCR tool

2. The Recognize Text dialogue box will open.
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Figure 2. Recognize Text dialogue box

3. Click the Edit button to configure the settings. A second dialogue box will appear:
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Figure 3. Recognize Text-Settings dialogue box

4. Define the following fields in the Recognize Text-Settings dialogue box: 

a. Primary OCR Language: English (US) 

b. PDF Output Style: Formatted Text & Graphics 

c. Downsample Images: Lowest (unless the document requires higher resolution images, but this will increase the file size).

5. Click OK to close the Recognize Text-Settings dialogue box and return to the Recognize Text dialogue box. 

6. Click OK to close the Recognize Text dialogue box and start the rendering process. This might take a few minutes to complete. 

7. If you try to render a PDF that is already a Text PDF, a message appears stating "Acrobat could not perform recognition (OCR) on the page because this page contains renderable text.”
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Figure 4. Message that appears if you try to render a file that is already a Text PDF

Checking your Rendered Text Document 

Once the document has gone through the OCR process, the PDF is a Text PDF. Unfortunately, this process doesn’t work perfectly. If Acrobat isn't able to translate something, it labels it as a “Suspect”. To ensure your document reads correctly, you must review these suspects and make any necessary corrections.

1. Go to the Document menu and then Recognize Text Using OCR.
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Figure 5. Path for accessing OCR tool

2. Option 1: Select Find First OCR Suspect.

a. The Find Element dialogue box will pop up showing the first OCR Suspect.  

[image: image7.png]Find Element

Findi [ OCR suspects v
Suspect: ().

OsearchPage (2 Search Document.
[_rodnoe ] [Accoptondrng ] [___cose

{84 AC 150/
Objects

) Ac 15018
(1) ac250/¢

The latest i
a for-sale p
£ron the Sup
Offics, Washi
ordering, alc

Aviation Nois
Pederal Aviat
fram the OFF:
Adminiatrati;

Tapact of No
Aviation Adud
Enviromenta.
800 Independ:

AR movie, "1





Figure 6. Find Element dialogue box

b. The suspect will be highlighted in the text and in the middle of the dialogue box. The tool’s text “interpretation” appears in the suspect field.

c. Make corrections in the Suspect field and then select Accept and Find. (You must “accept” a suspect for Acrobat to identify it as text. If you select Find Next, the suspect will remain as an image.)

d. If the OCR tool identifies a suspect that shouldn’t be read as text (object, image, rule line, etc.), select Not Text. This will leave the item as an image/object.

3. Option 2: Select Find All OCR Suspects.
a. The page or document will now have a rectangular red box around every OCR suspect.

b. When you click on a red box, the Find Element dialogue box will appear, allowing you to make and accept corrections, as discussed above. 

Text PDFs

A PDF with rendered and recognized text still requires work to ensure it includes—

· Correct “tags”

· Alternative text describing all images and objects that are not “background”

· Correct reading order 

· Bookmarks

· Document properties, including language assignment

Tags

“Tags” help assistive technology interpret documents by identifying the purpose of each element on the page (e.g., paragraph <p>, heading level 1 <h1>, table <table>, figure <figure>, list <l>, list item <li>, etc.). 

If you created a PDF from the source application and enabled tags in the conversion settings, your document should already be tagged. If not, you will need to add them.

1. Option 1: From the Advanced menu, select Accessibility and then Add Tags to Document. (This choice is best if your document is lengthy.)
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Figure 7. Path for accessing the Add Tags to Document option

2. Option 2: From the Advanced menu, select Accessibility and then TouchUp Reading Order. (This choice is best if your document is short because it allows more accurate tagging.) 
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Figure 8. TouchUp Reading Order dialogue box

a. Using your cursor, draw a rectangle around each piece of content to highlight it. (You must do this before many of the tagging choices in the TouchUp Reading Order dialogue box become available.)

i. If the item you wish to change is already grouped correctly, you may click on its number in the upper left corner (see Figure 9).

b. Tag each piece of content correctly, identifying headers, tables, figures, etc. separately

i. Be sure to identify background items (like rule lines) correctly so they will be tagged as “artifacts” and ignored by assistive technology.

ii. When your are done, your page should look something like this:
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Figure 9. Example of what a PDF page looks like when using the TouchUp Reading Order tool if the Show Page Content Order option is selected
iii. Note that the figures in Figure 9 are missing alternative text. See Alternative Text for Figures and Objects for guidance on adding alternative text.

3. Once you’ve added tags, you can view them by going to the View menu and selecting Navigation Tabs and then Tags.
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Figure 10. Path for accessing the Tags Panel

4. In the resulting Tags Panel, click on the "+" sign next to Tags to expand the listing and view the tags added to the document (this is called the tag tree). 
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Figure 11. Tags Panel (left) and Tags Panel (right) showing the expanded tag tree

Alternative Text for Figures and Objects

Alternative text is a short description describing an image or object that conveys information. It allows a person using assistive technology to interpret information that is conveyed visually. For example, Figure 11 could have the following alternative text associated with it: 

Figure 11. The Tags Panel showing a collapsed Tags listing (as indicated by a plus sign) (left) and the Tags Panel showing an expanded Tags listing or tag tree (right).

Note: If you created the PDF from a source document that already included alternative text and enabled tag creation in the conversion settings, the document should include that alternative text.

Note: In Acrobat, alternative text is referred to as “alternate” text.

1. Open the TouchUp Reading Order dialogue box as discussed in Step 2 of the Tags section. When you do this, you should see sections of content grouped as shown in Figure 12 below.

a. Identify any figures/objects missing alternative text. These items should be identified onscreen by a note that reads “No alternate text exists.”

b. Right click on the image and select Edit Alternate Text. 

2. Add a description of the figure in the resulting dialogue box. Do not start the description with “Image of” or “Figure of” unless it is important to convey that it is a particular kind of image (e.g., screenshot, photograph, diagram, flowchart, etc.).

Reading Order

You need to check if the reading order of your document is correct, especially if you used the Add Tags to Document option. As the name implies, reading order is the order in which assistive technology reads content to users. 

1. To review reading order, open the TouchUp Reading Order dialogue box.

a. As long as you have checked the Show Page Content Order option on the TouchUp Reading Order dialogue box, Acrobat will display the order in which content will be “read” by assistive technology (see numbers on content boxes in Figure 12). In the example below, some of the content is out of order (for example, the two text columns will not be read in consecutive order as they should be). This will hinder understanding of the document, so you should fix it.
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Figure 12. An example of a PDF page with incorrect reading order
2. To fix reading order—

a. Select the Show Order Panel button on the TouchUp Reading Order dialogue box (see Figure 8).

b. In the resulting Order Panel, select and drag the item that you need to move to its proper position.
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Figure 13. Order Panel showing the reading order of the document

Bookmarks

Bookmarks allow users to navigate through a PDF by clicking the bookmark names in the Bookmarks panel (see Figure 14). There are two ways to create new bookmarks.

Creating Bookmarks Individually

1. Create Bookmarks. 
a. Select text (or an image or part of an image) that you want to serve as the destination of the bookmark. 
b. Press Ctrl-B (or click the New Bookmark icon at the top of the Bookmarks tab). 
c. Repeat as necessary. 
2. In the Bookmarks panel, give the bookmark a descriptive title (preferable one that matches headings in the text).
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Figure 14. Bookmarks Panel 

Creating Bookmarks from Document Structure

If you have a document that has been tagged with headings, you can create bookmarks from those headings in one step.

1. From the Bookmarks panel, select Options and then New Bookmarks from Structure.
2. In the Structure Elements dialogue box, select the heading levels that you want to use for bookmarks (e.g., heading 1, heading 2).

3. Enter a title for the set of bookmarks (e.g., replace “Untitled” with “Contents”).

Document Properties

Section 508 requires authors to specify the language used in the document. The other document properties discussed below help visitors find documents online. Further, the Office of Communications is developing agency document standards that may stipulate their use. 

1. Go to File and Document Properties.

2. On the Advanced tab, make sure the Language field is set to “English US”.
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Figure 15. Document Properties dialogue box showing the available language options on the Advanced tab.

3. On the Description tab, insert useful entries in the Title, Author, Subject, and Keyword fields.
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Figure 16. Description tab of the Document Properties dialogue box
a. The Title should be clear and understandable and include the publication month and year and responsible office.

b. The Author field should include the responsible office.

c. The Subject should be a short, descriptive summary of the document.

d. Keywords should be specific and descriptive. Add at least two. Keywords should be lowercase, separated by commas with no spaces after commas (e.g., “baltimore washington international,bwi,record of approval,roa,noise compatibility”). 
i. When choosing keywords, think about what terms visitors might use to search for the document. If visitors might use either a full term (record of approval) or an acronym (roa), include both as keywords.
4. On the Initial View tab, set the Show option to Bookmarks Panel and Page.
Checking Accessibility

After you’ve added tags, alternative text, bookmarks, and document properties, you should be ready to check your work. 

1. Check the document with Acrobat’s built-in accessibility checker. The checker helps identify outstanding problems. While it can confirm that a compliance step has been taken, it cannot confirm if that step was done well (that is, if alternative text is complete or content is accurately tagged).

a. Go to the Advanced menu and select Accessibility and Full Check.
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Figure 17. Path for running a full check with the Accessibility Checker.

b. In the resulting dialogue box, you will see a listing of potential problems or a message saying the checker found no problems with the document. Click OK.
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Figure 18. Sample message generated by the Accessibility Checker.

c. The checker will produce a report (see sample in Figure 19). If the checker found problems, the report will recommend ways to resolve them.
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Figure 19. Sample Accessibility Report generated with the full accessibility check

2. Check how the document reads with the built-in Read Out Loud feature. This will help identify problems missed by the Accessibility checker.

a. Go to View and select Read Out Loud. You can choose to read either a single page or to the end of the document.

b. If the document does not read correctly, check the reading order or reassign tags for the problematic content.

3. If you have access to assistive technology like JAWS, consider testing the document with it to find out if it can interpret the document correctly.

Addressing Major Accessibility Problems

Missing Alternative Text

Missing alternative text is a common problem found during accessibility checks. Click through the Accessibility Report to determine if the identified figures or objects require alternative text or should be tagged as artifacts and moved to the background.

See Alternative Text for Figures and Objects and Tags for instructions.

Incorrect Tags

1. Option 1: See the Tags section to use the TouchUp Reading Order tool.

2. Option 2: Open the Tags Panel as discussed above. Use this option if the correct tag is not available in the TouchUp Reading Order tool (e.g., for list items, form labels, more heading levels, table header cells, etc.).

a. If the document is short and simple, you might be able to find the tag by scrolling through the tag tree. If it is long and has many tags, it might be easier to let Acrobat find it for you.

i. Highlight the content and then go to the Options menu in the Tags Panel.

ii. Select Find Tag From Selection. Acrobat will highlight the tag in the tag tree that contains the text you highlighted.
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Figure 20. Path for accessing the Find Tag from Selection option under the Options menu on the Tags Panel

iii. To confirm you have the right tag, return to the Options menu and select Highlight Content. (Alternatively, you can right click on the tag and select Highlight Content.) This will cause Acrobat to highlight the content associated with any tag you select in the tag tree.
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Figure 21. Path for accessing the Highlight Content option under the Options menu on the Tags Panel
b. Select the tag in the Tags Panel, return to the Options menu, and choose Properties.
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Figure 22. Path for accessing Properties under the Options menu on the Tags Panel
i. In the resulting TouchUp Properties dialogue box, go to the Tag tab and scroll through the Type menu.
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Figure 23. The menu for the Type field on the Tag tab of the TouchUp Properties dialogue box

ii. Select the correct tag Type.

c. You can also add alternative text on the Tag tab by filling in the Alternate Text field. 
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Figure 24. Alternate Text field on the Tag tab of the TouchUp Properties dialogue box

Inaccessible Content

Sometimes Acrobat will identify content as inaccessible. This usually occurs because a tag has not been assigned to the content or the content is really an artifact that should be moved to the background. 

See the Tags section for instructions.

Confirming Accessibility Fixes

Once you’ve corrected accessibility problems, recheck the document using the techniques described in the Checking for Section 508 Compliance section above.

Although this won’t guarantee that a document is perfectly accessible, it will demonstrate a good attempt to comply with the law. It will also result in a document that is much more accessible than it would otherwise have been.

Checking File Size

As a final step, you should check the file size of your document because some accessibility fixes can increase the size. 

Large PDFs can be difficult to download, so you should try to keep them to smaller than 3 MB. If they are larger and will be posted online, they may need to be broken up into smaller parts. Before breaking a PDF up, however, try to reduce its size. Although this process does not always work, it can sometimes reduce the size dramatically.

1. Check file size.

a. Go to File and Document Properties.

b. On the Description tab check the File Size in the Advanced section (see Figure 16).

2. If the size exceeds 1 or 2 MB, go to the File menu and select Reduce File Size.
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Figure 25. Path for accessing the Reduce File Size option under the File menu

3. Save the file if Acrobat ask you to do so.

4. In the resulting Reduce File Size dialogue box, set the Make Compatible With option to Acrobat 5 or later or Acrobat 6 or later. Although compatibility with more recent versions of Acrobat will reduce the file size even further, it will also prevent earlier versions of the Reader from being able to open the document.
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Figure 26. Reduce File Size dialogue box

5. Resave the document when prompted.

6. Repeat Step 1 to see if there was any reduction in size.

Checklist

	Issue
	Potential Problem
	Yes / No / NA

	Scanning Documents
	If you are scanning a document, is your scanner set to grayscale and to provide output of text and graphics? Is the dpi set to at least 300?
	

	Determining Type of PDF
	Is your file a scanned (image) PDF?
	

	
	If yes, see Scanned PDFs.
	

	
	If no, go to Text PDFs.
	

	Scanned PDFs
	Have you performed OCR?
	

	
	Have you reviewed all OCR suspects?
	

	Text PDFs
	Tags
	Have you added tags?
	

	
	
	Have you tagged unnecessary and background images as artifacts?
	

	
	
	Have you correctly tagged inaccessible content or moved it to the background?
	

	
	Alternative text
	Have you added alternative text for all figures/objects that need it?
	

	
	Reading Order
	Have you checked that the reading order is correct?
	

	
	Bookmarks
	Have you added bookmarks?
	

	
	Document Properties
	Have you assigned a language?
	

	
	
	Have you added title, author, subject, and keywords?
	

	
	
	Have you set the initial view to Bookmarks Panel and Page?
	

	Checking Accessibility
	Have you run a full check with the Accessibility Checker?
	

	
	Have you used the Read Out Loud feature to confirm tags and reading order is correct?
	

	
	If you have access to assistive technology, have you used it to confirm the document will be read correctly?
	

	Addressing Problems
	Have you fixed any accessibility problems identified in these checks?
	

	Confirming Fixes
	Have you rechecked accessibility after making fixes?
	

	Checking File Size
	Have you checked the file size and tried to reduce it if it exceeds 1 or 2 MBs?
	


The OCR suspect will be highlighted on the page.








PAGE  
18

