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Usage Notes

Overview

At the time of testing (September 20, 2010), Quattro Pro X5 lacks several features that enable accessible office document authoring, most notably: the ability to add longer descriptions to images and objects, the ability to create your own accessible templates, or change tracking features. As a result, some of the other features that might otherwise support accessibility, such as its extensive templates are not as effective. In addition, Quattro Pro X5 does not include an accessibility checking feature, which is a more advanced accessibility feature.
What’s an “Office Document”?

You should use these techniques when you are using Quattro Pro X5 to create documents that are: 

· Intended to be used by people (i.e., not computer code),

· Text-based (i.e., not simply images, although they may contain images),

· Fully printable (i.e., where dynamic features are limited to automatic page numbering, table of contents, etc. and do not include audio, video, or embedded interactivity),
· Self-contained (i.e., without hyperlinks to other documents, unlike web content), and 

· Typical of office-style workflows (Reports, letters, memos, budgets, presentations, etc.).
If you are creating forms, web pages, applications, or other dynamic and/or interactive content, these techniques will still be useful to you, but you should also consult the W3C-WAI Web Content Accessibility Guidelines (WCAG 2.0) because these are specifically designed to provide guidance for highly dynamic and/or interactive content.
File Formats

The default file format for Quattro Pro X5 is Quattro Pro (QPW). 

In addition, Excel 2010 offers many other spreadsheet processor and web format saving options. Most of these have not been checked for accessibility, but some information and/or instructions are available for the following formats in Technique 12 (below):
· MS Excel

· PDF 

· HTML

Document Conventions
We have tried to formulate these techniques so that they are useful to all authors, regardless of whether they use a mouse. However, for clarity there are several instances where mouse-only language is used. Below are the mouse-only terms and their keyboard alternatives:

*Right-click: To right-click with the keyboard, select the object using the Shift+Arrow keys and then press either (1) the “Right-Click” key (some keyboard have this to the right of the spacebar) or Shift+F10.
Disclaimer and Testing Details:
Following these techniques will increase the accessibility of your documents, but it does not guarantee accessibility to any specific disability groups.  In cases where more certainty is required, it is recommended that you test the office documents with end users with disabilities, including screen reader users.

The application-specific steps and screenshots in this document were created using Corel Quattro Pro X5 (ver.15.0.0.357, Windows XP, Sept. 2010).  Files are also easily saved as other file formats (see Technique 12, below).
Technique 1. Use Accessible Templates
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 At this time, it is not possible to create your own accessible templates in Quattro Pro X5.  When using the pre-existing templates it is important to ensure that you modify any inaccessible aspects of the template while editing in your document. [Tested: September 14th, 2010] 

All office documents start with a template, which can be as simple as a blank standard-sized page or as complex as a nearly complete document with text, graphics and other content. For example, a “Meeting Minutes” template might include headings for information relevant to a business meeting, such as “Actions” above a table with rows to denote time and columns for actions of the meeting.

Because templates provide the starting-point for so many documents, accessibility is critical. If you are unsure whether a template is accessible, you should check a sample document produced when the template is used (see Technique 11, below). 

Quattro Pro X5’s default template for new documents is a blank spreadsheet, which is accessible by virtue of being blank.
Technique 2. Set Document Language
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 At this time, it is not possible to indicate the natural language for specific cells or blocks of cells in Quattro Pro X5.  It is only possible to set the natural language for the current file. [Tested: September 10th, 2010]
In order for assistive technologies (e.g., screen readers) to be able to present your document accurately, it is important to indicate the natural language of the document.  If a different natural language is used for a paragraph or selected text, this also needs to be clearly indicated.
To set the language for the current file
1. Go to menu item: Tools > Thesaurus
2. In the Writing Tools dialog, select Options
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3. Select Language…
4. In the Select Language dialog, select a language from the scrolling list
5. Click OK
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6. In the Writing Tools dialog, click Close
Technique 3. Provide Text Alternatives for Images and Graphical Objects
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 At this time, it is not possible to add longer descriptions to images and graphical objects in a Quattro Pro X5 document. [Tested: September 14th, 2010] 
When using images or other graphical objects, such as charts and graphs, it is important to ensure that the information you intend to convey by the image is also conveyed to people who cannot see the image.  This can be accomplished by adding concise alternative text to each image. If an image is too complicated to concisely describe in the alternative text alone (artwork, flowcharts, etc.), provide a short text alternative and a longer description as well. 
Tips for writing alternative text
· Try to answer the question "what information is the image conveying?"
· If the image does not convey any useful information, leave the alternative text blank
· If the image contains meaningful text, ensure all of the text is replicated
· Alternative text should be fairly short, usually a sentence or less and rarely more than two sentences
· If more description is required (e.g., for a chart or graph), provide a short description in the alternative text (e.g., a summary of the trend) and more detail in the long description, see below
· Test by having others review the document with the images replaced by the alternative text
Tips for writing longer descriptions
· Long descriptions should be used when text alternatives (see above) are insufficient to answer the question "what information is the image conveying?"
· In some situations, the information being conveyed will be how an image looks (e.g., an artwork, architectural detail, etc.). In these cases, try to describe the image without making too many of your own assumptions.
· One approach is to imagine you are describing the image to a person over the phone
· Ensure that you still provide concise alternative text to help readers decide if they are interested in the longer description
Alternatively, you can include the same information conveyed by the image within the body of the document, providing the images as an alternate to the text. In that case, you do not have to provide alternate text within the image.
To add alternative text to images and graphical objects 

1. Right-click the object
2. Select Selection Properties… (F12)
3. In the Chart dialog, select the Object Name tab

4. In the Object Name text box, enter alternative text[image: image6.png]



Technique 4. Format Your Cells
As you begin adding content, your spreadsheet will require structuring to bring meaning to the data, make it easier to navigate, and help assistive technologies read it accurately.  One of the easiest ways to do this is to ensure that you properly format the cells.

4.1 Named Styles

You should make use of the named styles that are included with the office application (e.g., “Heading”, “Result”, etc.) before creating your own styles or using the character formatting tools directly.  Named styles help your readers understand why something was formatted in a given way, which is especially helpful when there are multiple reasons for the same formatting (e.g., it is common to use italics for emphasis, Latin terms and species names).

For more information on formatting using named styles, see Technique 9.

Note: While office application suites support headings in much the same way, the named styles often differ. 

Formatting header and result cells brings order to the spreadsheet and makes it easier for users to navigate effectively.   For example, you can format header rows and columns using “Heading” styles to apply bolded, enlarged, and italicized text (among other characteristics).  You may also want to format cells containing results of calculations to appear bold and underlined to help distinguish them from the rest of your data.

To format a cell with default named styles
1. Highlight the cells that you want to format
Note: to apply a style to an entire row or column, select the row or column indicator and follow the next steps
2. In the Property Bar, select the Style drop-down menu
3. Select a style to apply to the cells
4.2 Other Cell Characteristics
Ensure your cells are formatted to properly represent your data, including number and text attributes.
To format cell characteristics
1. Highlight the cells that you want to format

Note: to format a row or column, select the row or column indicator and follow the next steps

2. Go to menu item: Format > Selection Properties… (F12)
3. In the Active Cells dialog, select the relevant tabs (e.g. Numeric Format, Cell Font, etc.) and make your adjustments
4. Click OK
Note: When formatting your spreadsheet, it is best to avoid merging cells.  At times, it may seem easier to present your data by merging cells, but this can make it more difficult for users of assistive technologies and people navigating your spreadsheet using the keyboard. 

Technique 5. Use Cell Addressing
5.1 Define Names

Naming the different data ranges within your spreadsheet makes it easier to navigate through the document and find specific information.  By associating a meaningful name to a data range, you will be enhancing the readability of your document.  These named ranges can be referenced in multiple locations of your document and within calculations and equations.

To define a name

1. Select the cells you would like to name
2. Go to menu item: Insert > Name > Name cells… (Ctrl+F3)
3. In the Name box, type a unique name

Note: Duplicating existing names will overwrite the previous assignment of the name.

4. Click Add
Technique 6. Create Accessible Charts

Charts can be used to make data more understandable for some audiences.  However, it is important to ensure that your chart is as accessible as possible to all members of your audience.  All basic accessibility considerations that are applied to the rest of your document must also be applied to your charts and the elements within your charts.  For example, use shape and color, rather than color alone, to convey information.  As well, some further steps should be taken to ensure that the contents are your chart are appropriate labeled to give users reference points that will help them to correctly interpret the information. 

To create a chart

1. Highlight the data to include in the chart

2. Go to menu item: Insert > Chart > Use Chart Expert…
3. In the Expert dialog, format the available options and select Next > after each step

Note: Be sure not to skip Step 3, as it allows you to add titles and labels as you create the chart.

4. Select Finish
To add titles and labels

1. Right-click* the chart or go to menu item: Chart > Titles…
2. Select the available title check boxes (e.g. Main Title, Subtitle, Footnote, X-Axis Title, etc.)

3. Enter descriptive meaningful titles in each of the title text boxes

4. Select OK
Other Chart Considerations

· When creating line charts, use the formatting options to create different types of dotted lines to facilitate legibility for users who are color blind

· When creating bar charts, it is helpful to apply textures rather than colors to differentiate the bars

· Change the default colors to a color safe or gray-scale palette

· Use the formatting options to change predefined colors, ensuring that they align with sufficient contrast requirements (see Technique 9,  below)

Technique 7. Provide Structure for Tables
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 At this time, Quattro Pro X5 does not include an “Insert Table” feature. [Tested: December 8, 2010]
Technique 8. Use Other Content Structuring Features
While cell formatting is the most common method of structuring documents, other content structuring features should be used where appropriate:

8.1 Document Title
In case the document is ever converted into HTML, it should be given a descriptive and meaningful title. 
To change the title of the current document
1. Go to menu item: File > Properties…
2. In the Properties dialog, select the Summary tag
3. In the Title box, enter the Title
Note: The Title defined in the properties is different than the file name. It is also unrelated to the template name, discussed above. 
4. Click OK
8.2 Avoid “Floating” Elements

Avoid "floating" elements (other than charts) such as floating images, objects, tables or text boxes.

Similarly, avoid placing drawing objects directly into the document (e.g., as borders, to create a diagram). Instead, create borders with page layout tools and insert complete graphical objects.

Technique 9. Make Content Easier to See

9.1 Format of Text

When formatting text, especially when the text is likely to be printed, try to:

· Use font sizes between 12 and 18 points for cell contents.

· Use fonts of normal weight, rather than bold or light weight fonts.  If you do choose to use bold fonts for emphasis, use them sparingly. 

· Use standard fonts with clear spacing and easily recognized upper and lower case characters. Sans serif fonts (e.g., Arial, Verdana) may sometimes be easier to read than serif fonts (e.g., Times New Roman, Garamond).

· Avoid large amounts of text set all in caps, italic or underlined.

· Use normal or expanded character spacing, rather than condensed spacing.

· Avoid animated or scrolling text.

But can’t users just zoom in?  Office applications do typically include accessibility features such as the ability to magnify documents and support for high contrast modes. However, because printing is an important aspect of many workflows and changing font sizes directly will change documents details such the pagination, the layout of tables, etc., it is best practice to always format text for a reasonable degree of accessibility.

To change the text size for a default named style
1. Go to menu item: Format > Define Styles…
2. In the Define Style For text box, type the style name or click the arrow to open a drop-down menu where you can select the style you want to modify from the list
3. Click Font
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4. In the Size drop-down menu, select a font size between 12 and 18 points

5. Click OK
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6. In the Styles dialog, click OK
9.2 Use Sufficient Contrast

The visual presentation of text and images of text should have a contrast ratio of at least 4.5:1. To help you determine the contrast, here are some examples on a white background:
· Very good contrast (Foreground=black, Background=white, Ratio=21:1)

· Acceptable contrast (Foreground=#767676, Background=white, Ratio=4.54:1)
· Unacceptable contrast (Foreground=#AAAAAA, Background=white, Ratio=2.32:1)
Also, always use a single solid color for a text background rather than a pattern.

In order to determine whether the colors in your document have sufficient contrast, you can consult an online contrast checker, such as: 

· Juicy Studio: Luminosity Color Contrast Ratio Analyzer 

· Joe Dolson Color Contrast Spectrum Tester
· Joe Dolson Color Contrast Comparison
9.3 Avoid Using Color Alone 

Color should not be used as the only visual means of conveying information, indicating an action, prompting a response, or distinguishing a visual element.  In order to spot where color might be the only visual means of conveying information, you can create a screenshot of the document and then view it with online gray-scale converting tools, such as:

· GrayBit v2.0: Grayscale Conversion Contrast Accessibility Tool
9.4 Avoid Relying on Sensory Characteristics

The instructions provided for understanding and operating content should not rely solely on sensory characteristics such as the color or shape of content elements. Here are two examples:

· Do not track changes by simply changing the color of text you have edited and noting the color. Instead use the application’s change tracking feature to track changes.
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 At this time, Quattro Pro X5 does not offer a change tracking feature. [Tested: September 20th, 2010]
· Do not distinguish between images by referring to their appearance (e.g. “the bigger one”). Instead, label each image with a figure number and use that for references.

9.5 Avoid Using Images of Text

Before you use an image to control the presentation of text (e.g., to ensure a certain font or color combination), consider whether you can achieve the same result by styling “real text”. If this is not possible, as with logos containing stylized text, make sure to provide alternative text for the image following the techniques noted Technique 3, above.

Technique 10. Make Content Easier to Understand

10.1 Write Clearly

By taking the time to design your content in a consistent way, it will be easier to access, navigate and interpret for all users:

· Whenever possible, write clearly with short sentences.

· Introduce acronyms and spell out abbreviations.

· Avoid making the document too “busy” by using lots of whitespace and by avoiding too many different colors, fonts and images.

· If content is repeated on multiple pages within a document or within a set of documents (e.g., headings, footings, etc.), it should occur consistently each time it is repeated.  

10.2 Navigational Instructions

Provide a general description of the spreadsheet contents and instructions on how to navigate the data effectively.  The best way to do this is to make a cell at the beginning of the data (e.g., A1) with this information.  It will be the first cell accessed by assistive technologies.  If you are using this cell for a label or data, you can attach a comment note to the cell containing navigational instructions.
Technique 11. Check Accessibility
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 At this time, Quattro Pro X5 does not offer an accessibility checking feature to identify potential accessibility errors in your document prior to publishing. [Tested: September 20th, 2010]
In order to get some indication of the accessibility of your document or template (see Technique 1), then you may consider saving the file into HTML or PDF in order to perform an accessibility check in one of those formats, as described below.

To evaluate HTML accessibility
If you wish to check the accessibility of your document or template (see Technique 1, above), one option is to save it into HTML format and use one of the web accessibility checkers available online.  Such as:

· AChecker
· WebAIM Wave Web Accessibility Evaluation Tool
To evaluate PDF accessibility

If you saved your document in tagged PDF format, you can use the following tools and steps to evaluate the accessibility of the PDF document:

· Adobe Acrobat Professional

· PDF Accessibility Checker (PAC) – a free alternative provided by “Access for all” 

To evaluate PDF accessibility in Adobe Acrobat Professional

1. Go to menu item: Advanced > Accessibility > Full Check…
2. In the Full Check dialog, select all the checking option

3. Select the Start Checking button

Technique 12. Use Accessibility Features when Saving/Exporting to Other Formats

In some cases, additional steps must be taken in order to ensure accessibility information is preserved when saving/exporting to formats other than the default.

PDF
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 PDF documents are not always accessible. Accessible PDF documents are often called “Tagged PDF” because they include “tags” that encode structural information required for accessibility.  To evaluate the accessibility of your PDF document, see Technique 11 (above).

HTML
1. Go to menu item: File > Publish to Internet
2. In the Ranges and charts to convert section, click the Range Picker
3. Select a range of cells

4. Click Add
5. In the Export range as area, enable either the Table or Text options

6. Type a path and filename in the Save file box

7. Check the HTML file for accessibility (see Technique 11, above)
To clean up your HTML file

1. Remove unnecessary styles, line breaks, etc.

2. Remove unnecessary id, class, and attributes

3. Remove font tags

4. Remove styles in the <head> tag

5. Ensure the <th> tags have a scope attribute

6. Remove <p> tags nested inside <th> and <td> tags

7. Check for accessibility (see Technique 11, above)

Note: you may wish to use HTML editors or utilities to help with this process.
Technique 13. Consider Using Accessibility Support Applications/Plugins

Disclaimer: This list is provided for information purposes only. It is not exhaustive and inclusion of an application or plug-in on the list does not constitute a recommendation or guarantee of results.

· Accessibility features in WordPerfect Office X5 
Accessibility Help
If you are interested in what features are provided to make using Quattro Pro X5 more accessible to users, documentation is provided in the Help system: 
1. Go to menu item: Help > Help Topics
2. In the Quattro Pro Help dialog, select the Search tab in the left pane

3. Enter “accessibility features” as your search term in the search box
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