General Services Administration

Standards of Good Practice for - 

Sanitization of Sensitive but Unclassified (SBU) 

Data from Magnetic Storage Media

1 Introduction

This document presents standards of good practice for sanitization of SBU data.  

SBU data as defined in GSA IT Security Policy, CIO HB 2100.1A (Chapter 3, paragraph 26, a (1) is:
”Data is strictly controlled on a need-to-know basis to preserve confidentiality and integrity.  This group includes systems that contain proprietary information, records about individuals protected under the Privacy Act, E-commerce, financial, contracting, building drawings, and information not releasable under the Freedom of Information Act.”
2 Objective

This document describes standards of good practice used in the sanitization of SBU information.  Sanitization means the removal of data from storage media so that, for all practical purposes, the data cannot be retrieved.  Some instances in which sanitization must be considered include whenever media is transferred from one organization to another, when equipment is declared surplus, and when organizations dispose of media.       

3 Sanitization Techniques

Three techniques are commonly used for media sanitization: overwriting, degaussing, and destruction.  Overwriting and degaussing are the methods recommended for disposition of sensitive automated information depending on the sensitivity level of the data.

3.1 Overwriting

Overwriting is an effective method for clearing data from hard magnetic media (hard drives and disks, but not floppy disks or tape).  As the name implies, overwriting uses a program to write (1s, 0s, or a combination) onto the media.  Common practice is to overwrite the media three times in alternating fashion "1010101010 ..." then "0101010101 ...."  However, it is not uncommon to see overwrites of media up to eight times depending on the sensitivity level of the information.  Overwriting should not be confused with merely deleting the pointer to a file (which typically happens when a delete command is used).  

Overwriting requires that the media be in working order (ideally, a bad block map is made prior to sensitive data being introduced on the media and another map made after the overwrites).  If bad blocks develop after the initial mapping which are not corrected during the “overwrite,” then the “overwrite” is considered to have "failed" at least insofar as the data potentially resident in the bad block. Similarly if an initial bad block map was not made and bad blocks exist after the “overwrite,” we have to assume that sensitive data could potentially be on one of the bad blocks.  At the point it's a risk decision whether you accept the “overwrite” or move on to degaussing or physical destruction of the media.

3.2 Degaussing

Degaussing is a method to magnetically erase data from magnetic media.  Two types of degausser exist: strong permanent magnets and electric degaussers.  Degaussers come in a variety of strengths, and are generally categorized as Type I (weakest magnetic field) to Type III (strongest magnetic field).  Type I degaussers are not particularly useful given the proliferation of high density media -- they're just not strong enough.  Type II's are generally used for floppy disks, but are generally not strong enough for the high density hard disks which typically require the Type III degaussers.

3.3 Destruction

The final method of sanitization is destruction of the media by shredding, burning, sanding, or chemical decomposition. For hard disks, typically that means sanding to physically remove the top coated layers of the hard disk. Floppy disks and tape can sometimes be shredded. Burning and chemical decomposition generally pose some environmental hazards, and should be avoided if possible.

4 Sanitization of GSA SBU Data

GSA SBU information should be disposed of in a manner that precludes the possibility of the information being retrieved or reconstructed.  Prior to the disposal or recycling of magnetic media, the media should be reformatted or overwritten to minimize the possibility of retrieval or reconstruction of the information on the media.  All hard copy documentation should be shredded.   Unacceptable practices of complete erasure include a high-level file erase or high-level formatting that only removes the address location of the file. 

Each GSA programs should ensure that no SBU information exist on IT equipment that are scheduled for surplus, transfer, or donation.  The appropriate sanitization method should be used and ISSO/ISSM should verify that actions have been taken.

Information on systems and hard disks sent outside of your organization for repair or data recovery should be protected from disclosure by contract with the company performing the service.
The level of effort required to dispose of GSA data should be determined by the data sensitivity level and factored in both (1) the harm that may result if the information is inadequately protected, and (2) the cost of implementing available protective measures.

Appendix A “Overwriting GSA SBU Data” provides a general guide in overwriting SBU data using several commercial softwares.

Appendix A - Overwriting GSA SBU Data

Description
The following procedures can be used to treat workstations being removed from GSA-controlled premises to other, uncontrolled locations such as warehouses or transportation vehicles to distant locations.  They ensure that SBU data are not exposed to unauthorized agents while the equipment is beyond GSA control.

Inputs

1. Disk hardware specifications for each type of equipment to be sanitized.
2. Inventory of servers and workstations to be sanitized, identified by tag or serial number.
3. Disk wiping tools and associated users’ manuals.
4. Disk manufacturers’ standard base-level formatting utilities, for use in case the sanitizing procedure fails to access a partition with manufacturer-specific protections enabled.
5. Sanitization Certification Form (see Appendix B) for each machine or groups, signed by the responsible ISSO.
Process

Use the following procedures if the target workstation or server might contain a remnant of information that no current users need or for which they have no active access authorization. After sanitization, the target machine will require complete reloading of the standard operating system and software applications suite prior to reassignment.  The reloading operation is outside the scope of this process.

NOTE: After sanitizing, no normal disk rescue technique will be able to retrieve any data or programs on this device.  Therefore it is important to review machine contents and remove all possibly useful data before sanitization takes place.  The on-site ISSO should issue the Sanitization Certification Form (Appendix B) for each machine, certifying that this review and removal have been done.  After permission has been issued, perform the following steps.
1. Ensure that machine identity on the Sanitization Certification Form matches identity tags on the subject machine.  Initial the identity field on the Sanitization Certification Form to show that you have made this check.
2. Prepare bootable floppy disks as instructed by the sanitizing utility users’ manual.  The sanitizing programs run in main memory, from floppy disks.  Because they destroy all data on a hard drive, they cannot be run from the hard drive.
3. Perform the steps listed under section A or B. New Technologies Incorporated, DiskScrub, using the existing low-level partition formatting on the disk.
4. Verify that no data remain on the disk, using a text search utility such as DiskSearchPro™ by New Technologies Incorporated™ or Norton SystemWorks2002™ by Symantec.  Perform the steps under section C or D for this procedure.  These utilities access the disk through the primitive functions in the BIOS and bypass logical volume or partition formatting, which the sanitizing operation has usually destroyed.
5. If the text search utility finds no remaining data, proceed to Step 8.  If the text search utility finds readable data, perform Steps 6 and 7.
6. A readable data residue has been found after sanitizing. Using the disk manufacturer’s proprietary formatting utility, for example Seagate Seatools™, reformat the disk at the lowest level.  Set the formatter to remove all logical partitions, including those reserved for special functions such as Boot or Maintenance Sectors.
7. Return to Step 3 and proceed as directed.
8. When no residual data can be found, sign the Sanitization Certification Form, showing that the process is complete. Return the sanitized machine(s) to their owner(s) and collect a signed form for each, showing the machine inventory number(s), responsible owner(s) and date of return. 
9. Make any final comments on the Sanitization Certification Form listing the machine sanitized and noting any abnormal events during the process (see Appendix B for details).
A. Norton WipeInfo™
The Norton WipeInfo utility is a component of Norton Disk Utilities, release 2002:

1. Boot the computer from the A:\ disk drive in DOS mode.
2. Insert the floppy disk with the WipeInfo utility, and ensure that A:\ is the current primary drive.  Note: Booting from the A:\ drive should make it the primary device until changed via keyboard input.  This step simply ensures that the machine is following standard rules. 
3. At the A:\> prompt, enter wipeinfo from the keyboard.
4. WipeInfo signs on. At the Main Menu screen use the Tab key to select the Configure sub-menu.
5. Using the Space Bar, select the Government Wipe option.
6. Tab to the other settings on the Configure menu and confirm that WipeInfo is configured to overwrite 3 times for sensitive but unclassified data.
7. Tab to the Save Settings option and use the Return key to select enter.
8. Return to the Main Menu screen and select the Drives sub-menu.
9. Use the Space Bar to highlight the drive to be cleaned (c:, d:, etc.).  You will see a check mark by the drive once it is selected. (Note: Do this process for each drive present.)
10. On the Drives sub-menu, confirm that the Wipe Entire Drive option is selected
11. Select OK with the Enter key. This will return you to the Main Menu.
12. On the Main Menu, confirm the process by selecting Wipe with the Enter key.
13. Sanitizing of the selected hard drive proceeds.  When the process completes, repeat steps 8 through 12 for each additional drive present.

14. When all drives are sanitized, sign and date the Sanitization Certification Form for the subject machine to show that the process has been done.

B. New Technologies Incorporated - DiskScrubTM
1. Boot the computer in DOS mode.
2. Insert the floppy disk with the DiskScrub utility.
3. At the A:\> prompt, enter DiskScrub /d:all/p:3/g Three is the standard number of passes for sensitive-but-unclassified data.
4. When DiskScrub ends, sanitizing of the selected hard drive(s) is complete.
Sign and date the Sanitization Certification Form for the subject machine to show that the process has been done.

C. New Technologies Incorporated DiskSearchProTM
This utility verifies that no readable data remain on the disk after the sanitize operation.

1. Use a bootable floppy disk to boot the server or workstation in DOS mode.  At the A:\> prompt, insert the DiskSearchPro utility disk.
2. Type DS32 and press ENTER.
3. At the licensing and version information screen, press the ENTER key to Continue or use the right arrow key to move to the Quit key.
4. At the main menu screen, use the ß à arrow keys to move between pull-down menus.  Press ENTER to pull down a menu. From the Drive pull-down menu use the up/down arrow keys to select the drive you wish to search.  Press ENTER to confirm the selection. 
5. From the Source pull-down menu select the "File" option.  This selection directs DiskSearchPro to accept a keyword string from a floppy disk file and record results on another floppy disk file.  Note: For this search, any readable ASCII character except the one selected for "fill" during the wipe operation is of concern.  Presence of non-fill characters indicates that the wipe operation has missed part of the disk and will need to be repeated for the indicated sectors, after the disk has been reformatted at the lowest level.
6. From the Options pull-down menu use the TAB key to highlight options and the ENTER key to toggle menu items on/off.  Under the "Outputs" options, select the location where you want the text output to appear ("File" is recommended for most users).  "Other options" allows you to select sound alarm features and "Skip System Area" allows you designate areas of the system that you want your search to bypass.  The bypass feature will not operate on a disk that has no defined partitions.  Tab to OK and press ENTER to set your configurations.
7. When selecting the Begin pull-down menu, a prompt will appear asking you for the name and path of the keyword search file.  At this point press ENTER and the default list will appear in the Search Definition Window, where you may edit the list or change the accuracy setting (the default setting is 100%).  Do not set this value below 50%, because the search results become too vague and generic to provide useful output.  If you have not created a keyword search list, you may do so at this time in the Search Definition Window.  Make a list that includes the individual letters, (except for the letter used as the "fill" character, if that sanitization option has been chosen) numbers and commonly used special characters such as period, comma, backslash and parentheses.  It is recommended that you give your search list an eight-character DOS text name that matches the name of the system that you are searching (e.g., A:\AFR.TXT).  After creating a new list, tab to Save to disk and type the file and path name of the saved file at the prompt.  (Remember to direct this file to the A-disk; the hard disk is not formatted for data.)  Otherwise, tab to the OK button at the bottom of the window and press ENTER.
8. A prompt for a search output file name and path will appear.  Remove the DiskSearchPro utility disk from the floppy drive and insert the disk on which you are saving the search output files.  Enter the file and path names of the search output file.  Again, choose a name that matches the name of the drive or system being searched (e.g., A:\AFRSRVR1.TXT.  Note: Search text output file names must differ from those of the associated search keyword list file names).  Press ENTER to begin the search. 
9. The End-of-Search dialog box will appear when the search is complete.  Press OK to end the search and return to the main menu.  Since there are no other logical disk partitions to search, tab to the Quit pull-down menu and press ENTER to exit to the DOS prompt. Remove the search output text disk from the floppy drive.
NOTE: Search process will hang if output disk is removed while search is in progress.  If the search output disk fills to capacity before search is complete, simply replace the disk and press OK to resume.
10.Use the NotePad utility to see if there are any readable contents reported in the search output file.  It should be empty when a sanitized disk has been searched.  If it contains entries, repeat main procedure Step 6 until DiskSearchPro finds no readable characters on the sanitized disk.  Note: Utility GREP32 may be used to scan for specific character strings in the search output file.

D. Symantec Norton Diskedit from the SystemWorks2002TM Suit
This utility verifies that no readable data remain on the disk after the sanitize operation.

1. Reboot the target system in DOS mode.  Insert the DiskEdit diskette into the system floppy drive.
2. At the A:\> prompt, type diskedit.  A dialog box will appear in front of the main menu screen informing you that the program is in "Read Only" mode and that you should got to the Configuration option of the Tools pull-down menu to enable the program in "Write" mode.  Press OK with the ENTER key.  Use the ESC key to exit a dialog box or option at any time in this program.
3. At the main menu use the ALT key to access the pull-down menu bar.  Proceed to the Tools menu (use the down-arrow key to open the menu) and select Configuration.
4. Press the space bar to deselect the Read Only option.  Tab down to the Save button and press ENTER.  This will save your configuration update.  Press OK when the message box informs you of the save.
5. From the Object pull-down menu, select Drive.  In the drive selection dialog box, select the drive to be inspected for data.  Tab to the Type dialog box and use the space bar to select the Physical disks type.  Tab to OK to save your selections. 

6. From the Object pull-down menu, select Physical Sector. Using your Search Text Output file as a reference, enter the following physical sector location data for the partition you wish to access and edit:
· Cylinder [___]
· Side     [___]
· Sector   [___]
Toggle to the OK button and press ENTER.  For the sector number you may wish to enter a value less than that listed on your Search Text Output in order to find the beginning of the data area.
1. The sector you selected will probably appear as a hexadecimal display.  To change this to readable text, go to the View pull-down menu and select the as Text option.
2. You should see no readable text in this view.  If readable text other than the optional fill character appears, exit SystemWorks2002TM and return to main procedure Step 6.
3. Note: Norton SystemWorks2002TM has an optional sanitizing capability, which can be selectively applied to a particular file identified by its physical disk address parameters (Cylinder, Side and Sector values).  This Procedural Guide does not use the sanitizing function.
4. To select a new disk drive for inspection, return to the Drive option on the Object pull-down menu.
5. When you have completed all desired inspection, select Exit from the Object menu.  This will return you the DOS prompt.
Outputs

1. Sanitization Certification Form, (See Appendix B), listing the machines treated and any deviations from the standard process.

2. Sanitized machines for their return to owners. 

Appendix B - Sanitization Certification Form

	Sanitization Certification Form



	Organization


	GSA Decal #
	Status Codes:

1 = Working system –  operating system reinstalled

	Model #


	Serial #
	Status Code:
	2 = Won’t boot – hard drive removed or destroyed.



	Method of Removal



	Comments (if any)



	I certify that all data

and licensed software 

have been removed from 

this computer.
	Signature

	
	Printed Name of ISSO or Designee

	
	Date
	Phone


